Copyright Daves Drivers 2007-2016

Facebook Share

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
hl 340 serail to usb driver
#1
Dar all i brouth the serail to usb cable but could not find the drivers..

if anyone can help me i will be verymuch thankful
Reply
#2
Try reading this link. http://www.davesdrivers.com/forum/showth...hp?tid=130
Reply
#3
please i need vista 32 driver for usb to serial cable HL-340 .... this one is working with xp only ... but with vista ..it is useless
Reply
#4
did you try loading it with the compatibility wizard ?
have a read of this to find that little tool in vista.
http://www.davesdrivers.com/forum/showthread.php?tid=2
Reply
#5
Sad 
Dave do you still have the xp driver for hl 340 Please help me.
Reply
#6
yeah they are all over the forum software, most update one i ripped from a disk can be found here.
http://www.davesdrivers.com/forum/showth...130&page=9
others can be found here.
http://www.davesdrivers.com/forum/showth...130&page=7
and here.
http://www.davesdrivers.com/forum/showth...hp?tid=748
Reply
#7
Hi Dave, I have tried Catsmarty's procedure on an infamous fleEbay Blue HL 340 cable and have a few questions as I have attempted several different combos.
Toshiba 2410 laptop XP SP3

I have tried running all programs from the CD and also from the Desktop locations, Nada...same result, when the cable is plugged in (step 8) and auto install finishes, message is 'can't find the right driver' is there one of these I should use ?
http://www.davesdrivers.com/forum/showth...p?tid=1611

in step 6 there is a 'plug in cable' instruction :BUT there is no 'unplug' mentioned in the procedure.
Do you know if the USB should stay plugged in or out? The next mention is to replug in step 8 after reboot.

Or should the cable not be plugged in at all at this point?

I wanted to post to the original post but it is closed, is this a correct location?

thanks
EJ
Reply
#8
plug the cable in and call up its id string.
i might be able to find out what cross over chip is in your cable.

catsmarty's driver is just one of so many i hold on site.
you can try some of the others i have here.
http://www.davesdrivers.com/forum/showth...p?tid=1611

how to find a device id string
http://www.davesdrivers.com/forum/announ....php?aid=8

and remember these drivers are trying to access a port IE a usb port, a firewall or antivirus can kill the install stome dead if they block the port so its best to install the drivers with those programs shut down.
Reply
#9
Hi Dave,

retried the process with F/W and Antivir turned off, no change...

id = USB\VID_1A86&PID_7523\5%13446C9E&0&2

whatever is happening the USB is being added as an "other device" and not a com port

A friend helped me yesterday using Linux on his machine to identify that the cord really is a HL 340. The cable only has 340 imprinted.

the strange thing is that the first couple of times I tried the process I got a 2 tone 'beep' from the PC when I plugged in the cord, now I get 3 beeps but all the same tone AND I do not get the MS message to install a driver, I have to assume I am getting closer??

the part of Catsmarty's process I am puzzled by is the use of 3 installs, Huge Pine - don't know what it is?, HL 340 - assume this is the driver and then HL 2303 - from Prolific technologies, again don't know what it is.

here are the procedures I am having a go with, as in step 5 the HL340 asks for you to plug in , I guess ,to identify it... but Catsmarty did not mention this or if the cord should be unplugged.

5- Open the folder called HL-232-0108 and run the Setup For HugePine, if you get any messages press continue anyway.
6- Open the second folder called HL-232-340 and install the HL-340 and if you get any messages press continue anyway.
7- Open the folder called HL-232-2303 and then HL-2303, and run the HL-2303 setup, if you get a message saying to remove or reinstall, click on reinstall.

also in step 6 you have to manually close the 'action' window or it stays open and in the background.

thanks for the help
ej
Reply
#10
ok from what i can make out from that device id its a WCH HL-340/1 cable.

so this should be the correct driver.
http://wch.cn/download/list.asp?id=65.

if possible remove all drivers you have installed to date and restart the pc.
then install that driver but use a different usb port then the one you have been trying.

these cables don't like to be connected to a hub, they need a main usb port in order to work so if your using a hub remove it while you do this install.
Reply
#11
Shy 
Works like a charm, thank you so much
Reply




Users browsing this thread: 1 Guest(s)