Copyright Daves Drivers 2007-2017

Facebook Share

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
xp driver for usb to serial cable HL-340
#1
Hi all. I'm having trouble getting the HL-340 to work that I purchased off of E-bay. My cable came with no disk whatsoever. I saw this thread, which mentions a driver pack, but it has since been locked and the driver download is no longer available. I've tried the HL-340.exe that i found online and it doesn't change a thing.

When I plug the cable in XP recognizes it as "USB2.0-Ser!" under Other Devices in the device manager but it can't find any suitable drivers, even after running the HL-340.exe file.

Another forum directed me towards this driver but it won't work either. Can you please e-mail me the driver pack mentioned in the old thread, or provide some other suggestions? I'm starting to think that my cable is bunk, but I'll try it on another system first.

I'm on a 2.2ghz Intel MBP running OSX 10.5.5 with VMware fusion running XP Pro SP3.

Next I might try to boot natively into XP and see if it makes a difference.
Reply
#2
not 100% sure if these drivers work with sp3, only seen them work under xp xp sp1 and xpsp2

sp3 does make some core changes to xp its self.
the only driver i moved as i got fed up of teh bots linking to it is catsmay driver and that can be found in the download section on the bottom of the forum.

download section/ usb
the driver download does work as i just tested it myself.
sorry can't email that driver as the zipsize is too big and will get rejected by your pop account.
Reply
#3
Thanks Dave's Drivers... I answered my own question with the handy "possibly related threads" feature. (why isn't that on any other forums?)

well, i didn't need to try it booted natively into XP because it seems as if the vista/updated xp drivers, CH341SER.exe, mentioned in another thread worked perfectly. I found it here: http://wch.cn/download/list.asp?id=65 Even though it worked, the file did stop responding during install, and when I tried to uninstall it and reinstall it and make sure it installed correctly, it crashed VMware in the uninstall. So I just left it alone while it still works.

the cable now reads as "USB-Serial CH340" under ports in device manager. the only problem is that it's on COM6, and i can only use com1-4 for VAG-COM. when I go into the advanced button under the port settings in the device properties tab, it says that com1-5 are in use.... any help there?
Reply
#4
does it list what is using com port 1 ?

if it does you maybe able to switch the device thats using it in your bios settings under IRQ

if that fails see if the port settings will allow it to share the two devices.
Reply
#5
yeah I was able to switch whatever was on com1 to com7 and then put the usb-serial cable from com 6 to com1. however, since they're all virtual ports on a virtual machine, the VAG-COM cable will say it has a good connection but won't read the car's ecu. next i'm going to try booting natively into windows and see if it makes a difference. thanks again for the responses.
Reply
#6
Wow, about a full day of searching, downloading, trying and failing. Finally FirstOrbit's driver CH341SER.exe worked. Many thanks! I suspect the previous drivers were choking on SP3, BTW...
-gardoni
Reply
#7
hi does anyone have a driver for a vista, i have an usb to serial cable HL-340 but i cant get a driver, some help would be great.thanks.
Reply
#8
depends on what chipset is inside your cable the most up to date driver i have for vista can be found here but its for the 2303 chipsets.
http://www.davesdrivers.com/forum/showth...335&page=3
Reply
#9
Cool 
Hi there, tkank you a lot for the driver, I have already prove my HL-340 cable in an XP SP3 and it worked excellent, I also tried with the other driver (HL-340.exe) with no succeded, maybe that is only for SP1 and SP2.

The chineese driver is fine for SP3.

Thx again.
Reply
#10
Hi!, I am new.
Sorry for my english, but i'm Italian.

Where is exactly the download section of the forum. I'm not able to find it.
I need catsmay drive to try with my usb-232 cable.

Thank you
Hi !

Can you send me your driver?

My mail is stefano.chi@tiscali.it

Thank you.
Reply
#11
the part of the download section your looking for is here.
http://www.davesdrivers.com/forum/showth...hp?tid=748

sorry driver is just over the limit to send to most email accounts please download it by logging in to your account.


for info the download section can be found on the bottom of the main forum once you log in to your account.
can not be seen by non members, thats to protect my downloads from bots that link to them and run up my usage allowance.
Reply
#12
Thank you very much.

I'm downloading it...
Hi,
The Catsmay files downloaded are not working in my case.

But I found a new driver that works immediatly very well. I bought recently a blu usb-serial cable marked HL-340 and the only one good driver tested by me is the follow:

CH341SER.EXE 121KB REL. 2.7.2007.07

If you need this file, please tell me how I can give you it.

Bye bye
:thankyou:
Reply
#13
that sounds like a early wch driver.

if you like being only 121KB in size it will email , but emails to do accpet .exe file extentions what you will need to do is put the driver inside a folder, then use winzip or winrar and pack the driver up.
it will then make the size even smaller and you will be able to email it.

if you do that you can email it to me at this site at

davesdrivers @ live.co.uk

for info the most up to date that wch have is last year dated 2008-10-17
and that one can be found here, http://wch.cn/download/list.asp?id=65
Reply
#14
stefano.chi driver can be found on the bottom of this post
version number and make is
WCH.CN
|__ USB-SERIAL CH340
|__ 09/24/2007, 2.8.2007.09

newest version i could find at WCH.CN is
WCH.CN
|__ USB-SERIAL CH340
|__ 10/16/2008, 2.9.2008.10

also found on this post.


Attached Files
.zip   CH341ser.zip (Size: 119.5 KB / Downloads: 282)
.zip   CH341newer.zip (Size: 144.96 KB / Downloads: 395)
Reply
#15
Just found this site. Thanks for the input. Some reason mine will still not load. I dl'ed your driver, says it is installed, but it still consistently comes up as "new hardware found". I tried uninstalling it and redoing it but no good. Ever run into a problem like this?
Thanks!
Reply
#16
did you try some of the other drivers listed here
http://www.davesdrivers.com/forum/showth...130&page=9
http://www.davesdrivers.com/forum/showth...130&page=7
and here
http://www.davesdrivers.com/forum/showth...hp?tid=748

one of them may work for you.
Reply
#17
(10-15-2008, 09:14 PM)FirstOrbit84 Wrote: Thanks Dave's Drivers... I answered my own question with the handy "possibly related threads" feature. (why isn't that on any other forums?)

well, i didn't need to try it booted natively into XP because it seems as if the vista/updated xp drivers, CH341SER.exe, mentioned in another thread worked perfectly. I found it here: http://wch.cn/download/list.asp?id=65 Even though it worked, the file did stop responding during install, and when I tried to uninstall it and reinstall it and make sure it installed correctly, it crashed VMware in the uninstall. So I just left it alone while it still works.

the cable now reads as "USB-Serial CH340" under ports in device manager. the only problem is that it's on COM6, and i can only use com1-4 for VAG-COM. when I go into the advanced button under the port settings in the device properties tab, it says that com1-5 are in use.... any help there?
thanks for this guys really appreciate the help, i also bought a cheepie of ebay HL340 and after this install it pick up on com 19. thanks once againGrin
Reply
#18
if you go in to the settings of the cable you can change what port its using as long as you have no other hardware in the pc already using the same port.

com port 3 is normaly for a dail up modem and if you don't have one in your pc its should be safe to use that.
i did upload a manual for these cables as well so may be worth your while flicking through the pages of that was well.
http://www.davesdrivers.com/forum/showth...335&page=3
Reply
#19
obrigado pelo driver
Reply
#20
(01-03-2009, 11:56 PM)davey6 Wrote: the part of the download section your looking for is here.
http://www.davesdrivers.com/forum/showth...hp?tid=748

sorry driver is just over the limit to send to most email accounts please download it by logging in to your account.


for info the download section can be found on the bottom of the main forum once you log in to your account.
can not be seen by non members, thats to protect my downloads from bots that link to them and run up my usage allowance.

Hello...this is the right driver for HL-340...is the second setup from the archive....
Thanks.....
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  x64 driver for HL-340 usb > serial device MASTER-M 28 88,651 12-17-2012, 06:40 PM
Last Post: nam183sai
  USB-Serial Cable work in 7-N-1 but not 8-N-1? gbock 3 5,423 01-05-2011, 08:47 PM
Last Post: davey6
Sad new xp driver for usb to serial cable HL-340 tatoox 1 5,870 06-12-2010, 10:50 AM
Last Post: davey6
  HL-340 USB-Serial cable for XP rufo 11 55,173 05-12-2010, 04:11 AM
Last Post: jg161
  xp driver for usb to serial cable HL-340 coolman 19 69,198 03-06-2010, 12:46 AM
Last Post: mostafa khalil



Users browsing this thread: 1 Guest(s)