Copyright Daves Drivers 2007-2018

Facebook Share

Thread Rating:
  • 2 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
xp driver for usb to serial cable HL-340
#21
davey6 Wrote:if the computer is calling up Nokia DKU 5 then thats what it must be.

does it have a name listed on the usb plug as per the photo at nokia ?
have a read of the install guide found here along with the correct driver.

http://www.nokia.com/appmanager/UnitedSt...indowState=


The cable looks completely different to the one on the nokia website, its one of those blue ones off ebay - http://cgi.ebay.co.uk/USB-TO-COM-Port-Se...otohosting

i will try the nokia install again, thanks for your reply!
#22
Im having no luck at all with the nokia drivers, I install them, then insert the usb cable and it says its detcted the nokia cable, then no matter whether i try and do it automatically or try and install the drivers through device manager it just isn't happening! The cable itself says HL-340, windows says its nokia and im totally stuck! any help will be much appreciated!
#23
ok , what are you trying to connect to the pc by this cable?

you may need the drivers for the device your connecting as well as the cable
#24
davey6 Wrote:ok , what are you trying to connect to the pc by this cable?

you may need the drivers for the device your connecting as well as the cable

I'm connecting an aiptek graphics pad, but even when I try connecting it all together it still only detects the nokia cable.... im on a vaio laptop, so it has no serial ports.. does anyone else's computer detect a nokia wire when they attach these blue cables from ebay?
#25
ok this is just a idea.
do you have access to a desktop with a serial port ?
if so try the cable the other way round and see if it accepts my driver or the nokia driver.

I have a feeling your trying to run the patch cable backwards and it may not like doing that.

I am not sure if they still make them or not but they use to make a 9pin din to usb stub connector bit like a svga to dvi.
i think that would work better for you.

also what windows are you trying this driver with ?
is it vista by any chance ?
#26
davey6 Wrote:ok this is just a idea.
do you have access to a desktop with a serial port ?
if so try the cable the other way round and see if it accepts my driver or the nokia driver.

I have a feeling your trying to run the patch cable backwards and it may not like doing that.

I am not sure if they still make them or not but they use to make a 9pin din to usb stub connector bit like a svga to dvi.
i think that would work better for you.

also what windows are you trying this driver with ?
is it vista by any chance ?

Nope im on xp.. i do have a desktop with serial, and ill try that out, thanks for your help! i think ive been sent the wrong cable by the distributors, it came with a driver cd for a card reader for some reason, ive emailed them though they did reply.. the engineer be back for you tomorrow, he has went home... probably the wrong chip in the cable or something!
#27
Thanks hl-340 USB
#28
Ive bought this cable from ebay aswell.

Im atempting to connect my cars ecu to it (its designed that way).

The drivers on the cd are for a card reader, and when u plug the calbe in the computer tells me about a nokia dku cable and it cant find drivers.

Im connecting the usb to the usb on my laptop (XP)
And the serial end is going to my cars ECU.

Dodgy calbes ??.

Im getting rite pissed off with it.
#29
may well be a bad seller at ebay if his giving out card reader drivers for a patch cable, he may even have a bad batch of cables that he don't know about,

try the driver i have on site here, and email the seller at ebay and tell him his sent you a card reader driver for a usb to dsub patch cable, if you get no reply from him report him to ebay, don't let bad sellers get away with it.
#30
I also bought the blue HL-340 cable from Ebay. I wanted to connect a Serial GPS to my computer via USB emulation. Both the CD driver included with the cable, and the driver from this website recognize the cable as CH340. I don't know if HL-340 and CH340 are the same things. All I know is that the cable does not work for my application.

I have a more expensive locally purchased offbrand USB-serial cable (PPA Int'l brand) that works perfectly. So, I guess I keep this one and toss the Ebay cable.

I just thought people would like to know that the blue Ebay cable/driver may not function in the same way as other brands for certain applications.

Ray
#31
CH340 is the little switch chip inside the cable.

the cable may well be wired incorrect, your the second or third person to say these cables from ebay don't work so i thinks its best to stay away from them.
#32
I have one of the blue cables also, though I did not get it for 49p off ebay. Anyway I have tried every suggestion here and still no luck installing a driver on either a Toshiba satellite running xp pro or a dell dimension desktop running xp home. Tired of wasting time with this, I may have to just bin the cable, pity.
#33
Hey everyone I found the driver for this cable at the link posted below..

http://www.dvd9.nl/hl-340.html
#34
thanks for the link but its the same driver i already have in this topic ,
version 1.31
#35
hi! i have the same cable too. it came with a small cd that contained a setup file for the driver. i installed the driver and my winxp device manager recognized the usb to serial (com5) port. however, i cant seem to establish a connection with my 3com us robotics 56k (external) message modem.

the modem works as i had my brother test it on his winxp rig which had a serial port. my motherboard doesnt have one, thus the usb to serial cable.

i tried different drivers including the one posted here, but no luck.

my modem comes with a serial cable and i use it to attach to the usb-serial cable. i downloaded the driver from us robotics, tried installing it by using add hardware, but whenever i reach the point where winxp asks - on which port do you like to install it? - there are no ports to select.

i hope you guys could help me here.
#36
the problem is the us robotics modem is pre set in its hard ware to use com port one or two.
thats normal or should i say old serial port settings the cable will not change that fact.
if the driver is installing which going by your post it is, i am sorry to say that this modem may not work by such a cable.
#37
Brought the blue transparent cable from eBay(a HK seller). The small CD comes with can't be read by T60p's CD-ROM. Once I download the driver posted it here, it works for me! Save me time to mess around! Thank you so much!
#38
bvjb Wrote:hi! i have the same cable too. it came with a small cd that contained a setup file for the driver. i installed the driver and my winxp device manager recognized the usb to serial (com5) port. however, i cant seem to establish a connection with my 3com us robotics 56k (external) message modem.

the modem works as i had my brother test it on his winxp rig which had a serial port. my motherboard doesnt have one, thus the usb to serial cable.

i tried different drivers including the one posted here, but no luck.

my modem comes with a serial cable and i use it to attach to the usb-serial cable. i downloaded the driver from us robotics, tried installing it by using add hardware, but whenever i reach the point where winxp asks - on which port do you like to install it? - there are no ports to select.

i hope you guys could help me here.

Its possible to change the com port used by the cable. Go into device manager, double click on the CH340 port and then go to the port settings, advanced and then you can select which port you want it to go on. If windows reports that ports 1 and 2 are in use - ignore it and just ay yes to the warning.
You can get detailed instructions here.

http://www.help.perle.com/printable.asp?q=32

Ignore the bit about creating a phantom port, just use the one assigned to your cable.

Thanks for providing the driver Dave! I was having the same trouble and the drivers that came with the cable were actually for a chip manufactured by FTDI - I spent a couple of hours trying to modify the .inf files but couldn't get it to work. Your drivers seem ok so far.

Good luck
#39
cptasker Wrote:
davey6 Wrote:if the computer is calling up Nokia DKU 5 then thats what it must be.

does it have a name listed on the usb plug as per the photo at nokia ?
have a read of the install guide found here along with the correct driver.

http://www.nokia.com/appmanager/UnitedSt...indowState=


The cable looks completely different to the one on the nokia website, its one of those blue ones off ebay - http://cgi.ebay.co.uk/USB-TO-COM-Port-Se...otohosting

i will try the nokia install again, thanks for your reply!


I bought the same cable from the same ebay seller and none of the drivers here or any where worked for me, it came with card reader's mini CD too, I will through it in the bin now
#40
davey6, thanks for putting up the driver! Yours was the only place where I found it! Keep it up.


Possibly Related Threads...
Thread Author Replies Views Last Post
  x64 driver for HL-340 usb > serial device MASTER-M 28 119,362 12-17-2012, 06:40 PM
Last Post: nam183sai
  xp driver for usb to serial cable HL-340 FirstOrbit84 29 115,424 03-04-2012, 10:14 PM
Last Post: davey6
  USB-Serial Cable work in 7-N-1 but not 8-N-1? gbock 3 8,675 01-05-2011, 08:47 PM
Last Post: davey6
Sad new xp driver for usb to serial cable HL-340 tatoox 1 8,291 06-12-2010, 10:50 AM
Last Post: davey6
  HL-340 USB-Serial cable for XP rufo 11 64,063 05-12-2010, 04:11 AM
Last Post: jg161



Users browsing this thread: 1 Guest(s)