Copyright Daves Drivers 2007-2016

Facebook Share

HugePine USB-UART in Win7 x64
#1
Hi Dave, hi all!

I used to use a USB-UART Adapter using the supplied HugePine drivers. Worked perfectly in Windows XP 32-bit and Vista 32-bit. No problems.

Now I switched to Win7 x64 and I can't get it up and running.
Installaing the drivers with Setup_for_HugePine.exe doesn't do anything. The cable is not recognized.
I tried all of your downloadable drivers and the HL-340, which was recommended to me doesn't install. I only get "Installation failure".

I ran a Windows XP 32-bit VirtualMachine in Win7x64 and the Hugepine driver was immediately installed and works. But of course that's not what I am after, especially as I get BlueScreens quite often in WinXP using the RS232 adapter.

I hope you guys can help me out :(

Hardware ID:
USB\VID_6547&PID_0232&REV_0001
Reply
#2
its not so much the switch to windows 7 thats has stopped that cable working.
if it has vista drivers its a newer chipset.
whats stopping is lack of 64bit driver support for all of these cables.

at the moment till 64bit becomes the norm people won't bother making the driver.

contact HugePine direct ask them if the plan on supporting their product under windows 64bit.

that device id string is coming back as a nokia CA-42 cable,
nokia only offer basic windows xp drivers for that cable.
http://www.nokia.co.uk/get-support-and-s...-70-ca-101

what you can try is the compatibility wizard with that cables driver.
i know this is all about vista but the wizard remains the same in windows 7 so have a quick look over this and try it with that driver.

http://www.davesdrivers.com/forum/showthread.php?tid=2
Reply
#3
unfortunately the compatibility wizard always ends with detecting the hugepine software as incompatible.

the only driver of the many ones you posted in your other thread, that actually pretended to work was the ftdi whql certified one. windows claimed that the cable had been initialized and was working but it didn't do anything. so i doubt it really worked.

stupid x64 :(
Reply
#4
at the moment we are really stuck when it comes to 64bit drivers

its not just these cables, a whole range of hardware does not have any 64bit drivers out,

till 64bit takes over from 32bit in the normal everyday computer world the hardware companies just don't bother doing the drivers.

like your self i do have windows 7 64bit on one of my machines.
i had to sit and do work rounds myself for some of my older hardware because of lack of support.

drives you mad really.

if you don't like windows xp mode think about a dual boot system like i have.
windows xp and windows 7.
that way you can choose to start in what ever version of windows you need at that time.
Reply
#5
i'm not a big fan of dual or multiboot.
and i prefer VM to windows pseudo-vm.

but i did try ubuntu 9.10 x64 and it recognized and supported the cable immediately!
it says its a ark3116 converter and it works right away.

so, as i have BlueScreens with XP, I will be using it in a ubuntu vm.

still, weird that it works in a 64bit linux (someone made the 64bit version of the driver for linux) but no one ever bothered to make the 64bit windows driver.
Reply
#6
funny thing about linux is it does support a wide range of hardware.
but the servers run on that and 64bit is norm these days for servers.

if linux done everything i needed it to i would switch over to that.
i just find it a pain in the backside to work with at times

out of all the version i think linux mint is the most user friendy of the bunch.

mind you i still like my old amgia workbench over that of windows.

now i am showing my age lol lol

never had a problem with dual boot myself, but i know some people do.

glad you got it sorted out and i will keep a eye open for 64bit drivers.
they have got to start doing some soon.
Reply




Users browsing this thread: 1 Guest(s)