Davesdrivers copyright 2007-2022

Thread Rating:
  • 1 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
HL USB-RS232 Cable Windows doesn't recognize
Hi, I bough a HL USB-RS232 Cable from Amazon.com. The cable has greenish-blue transparent ends with a silver cable. It came with a cd that was broken, so I contacted the company (brilliantstore.com) and they sent the driver. However it doesn't work and neither has any of the other drivers I've tried from various places and this site.

When the cable is plugged in Xp recognizes it immediately as a PS/2+USB mouse and then installs it as a Human Interface Device. Usually later Windows flashes the message that it is an unknown device that isn't working properly and tells me to reinsert it or get a new device. I've tried manually updating the driver from the human interface device tab in the device manager but it always says the software i try isn't as good as what windows has and leaves it as a HID. I've also tried uninstalling HID, installing a driver, and then plugging the cable in, but it always auto-installs it as a human interface device.

Any help is appreciated. Thanks
windows is getting confused by the crossover chipset in the cable.
in other words windows thinks it knows better then you do.
force windows to accept the driver they sent you for the deviice.
use the add hardware wizard from control panel call up the problem device when windows wants to search for a better driver thats the time you tell it have disk and load then one they sent you.
windows might warn you that the driver is not a good match or it does not support that cable click continue and override windows.

that i think is your best chance of getting the driver you want installed without windows sticking its nose in to what your doing.

that sounds like a new cable, if possible call up its device id string and i will see if i can find out what cross over chipset is being used.
When I plug the cable in, two devices appear in the device manager.

HID-compliant device
Device Instance ID:

Hardware IDs:


USB Human Interface Device
Device Instance ID:

Hardware IDs:

I tried manually installing through the add hardware wizard like you suggested. Windows comes up with the "Could not find a better match" message again. When I uninstall drivers and then plug the cable in, windows automatically installs the HID drivers without even asking me if I have a cd or files.

The seller sent me two folder one called
CPA1031-DRV and another called

The CPA folder has a driver uninstaller and .sys, .inf, and .vxd files. The HL-340 folder has the installer. Iv'e tried running the installer, and it says sucess, but then when I plug the cable in windows installs it as a HID again.

Thanks for the quick reply!
well thats a cypress cross over chipset.
they do have a download section however i am having trouble trying to find the cable you have.

have a look over this site.
you can also try the driver set listed here as a few people said these work with that cable.
but what works for some people does not always work for others as i have found out dealing with these.
look on the bottom of that page for the drivers

I can't really find anything on the Cypress Website and I already tried the drivers at the other link. However, another thread on your site lead me to this website. The cable pictured looks like mine and in the thread it was mentioned that that cable had a cypress chipset too. The website talks about the issue of windows installing the cable as a HID, and tells how to fix it, but they don't have a download link for the driver.


It didn't seem like the person in the other thread got anywhere with it either. :(

I think I found the driver here!!!!!!:

I followed the instructions at this site to change it from HID to the COM4 port and that's what it is showing up as in the device manager!!!!:


I'll definately let you know if it works out when I connect the device i'm trying to export data from (Genesys 10 Spectrophotometer), but it seems to have created a new COM port so far!

Thank you for all your help!!
one word of advice, if that is a old device the Genesys 10 Spectrophotometer it may not work on comm port 4.
older device's use the standard comm port settings of early pc which means you might have to change that to comm port 1 or 2 in order to get it working.
i grabbed that driver you never know might help someone else the more of these i can lay my paws on the better,

if you need it again you will find it here listed as cypress usb

Well when I restart it or unplug the cable and plug it back in it still shows up on the device manager as a com port. :) So that seems to be working.

However, I'm still not receiving any data from my device. I changed the port to COM1 in the device manager and set up hyperterminal similarly. Are there any other settings for old devices that I should try. The user manual for the device gives baud rate, data bits, parity, and stop bit and I have set all of these to what they should be on both sides of the connection. Thanks Again!
sometimes the driver is only part of the transfer, some older devices also needed software in order to get info from a device,

its a bit like mobile phone software, the driver only gives you part access the full software allows you to do much more.

by the look of it you will also need the VISIONlite software suite

there is a few demo's of that software here.
Hmm, I also emailed technical support, and they said that Hyperterminal was the only software required to export data. I didn't ask them about the USB to rs-232 setup though. Is it possible that the device is setup so that it will only work from serial port to serial port. The manual said to use a DB9 (female) to DB9 (female) cable, but I just assumed that the converter would "convert" correctly. The manual also gives a chart that tells each pin's function.

2: Transmit Data
3: Receive Data
5: Ground
7: Clear to Send
8: Request to Send

1: Data Carrier Detect
2: Receive Data
3: Transmit Data
4: Data Terminal Ready
5: Signal Ground
6: Data Set Ready
7: Request to Send
8: Clear to Send
9: Ring Indicator

I emailed the company again, but I though I'd see if you had any ideas too because you seem just as knowledgeable on the subject as they are. :) Thanks
it may be the case if this device is old that it will only work on the older type machine, the cross over chip has to slow the speed of usb to that of the old serial and control the data as well.
sometimes it does not work the way it should.

under Hyperterminal is it connecting to the device.
Hyperterminal works almost the same as your net it gives the device a ip address so it can connect to the device.

if its not connecting try the following
restart the pc and shut down any firewall and anti-virus software you may be using, connect the cable then connect to the device.

not sure if you have a desktop or laptop, some desktop computers still have a serial header on the motherboard and it is possible to buy the cable and port cheap on ebay and give your board that all inportant serial port that you need.
even my own board which is the X48T chipset still has such a header in case its needed.
When I create a new connection in hyperterminal, after I click ok it says connected in the bottom left and has a timer showing how long its been connected for. However, it will also do this when the cable isn't even connected to the device. Is there a more definative way to tell if its connecting/seeing the device? Or seeing what ip its assigning the device?

I tried restarting and disabling the firewall and anti-virus, but no luck receiving data.

The computer has a serial port, so I may have to buy a serial cable and try it that way. The reason we tried usb was so we could use the device with labtops as well.

Thanks again for all of your help!
you should be able to see the ip address this way.
connect by hyperterminal, go in to control panel , network connections then call up that connection.

you can also check the send signal this way.
with the hyperterminal windows open type AT
hit enter it should come back with OK

now thats a old device and it should be serial to serial so its using the older modem settings.
i just wonder if you should be using a null modem cable ( cross over ) or a straight cable.
only their technical support will be able to answer that question.

i am pretty sure those usb to serial are a straight cable connect without the cross over as per the null cables.
I don't get any response when I type AT, so I don't think its making a connection even though it says connected.

I did find a db9 serial to db9 serial cable though and tried that out. It worked on the first try, I didn't even have to tinker around with any settings! So I guess I can use that for now and forget about laptop use for a while.

I'll keep trying though, maybe it will eventually work :)
do you know if that serial to serial you used is straight or null ?
Hey, i have the exact same device.

But, I am running windows 7 x64.
Those drivers dont work.

I tried searching all over.
windows 64bit is not supported by 99% of the early cables.
the cables that you can buy on ebay e.t.c are out of date and no longer supported.

when it comes to the likes of windows 7 64 a brand new cable from a top company such as belkin is your only real option.


Possibly Related Threads…
Thread Author Replies Views Last Post
  HL340 good driver, but XP doesn't let me pick it! gbock 14 28,620 05-12-2011, 03:12 AM
Last Post: c-driver
  HL-340 RS232 CALE DRIVER NEEDED. truong 1 7,945 07-26-2008, 05:51 AM
Last Post: davey6

Users browsing this thread: 1 Guest(s)