Copyright Daves Drivers 2007-2016

Facebook Share

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
USB Device Not Recognized
#1
Im a complete novice at this, so here goes.

I have a Fujitsu Siemens Amilo Li 1718, running Vista basic. I have 4 ports that for some reason dont work. Each time i try to connect a usb device i get the following message: "USB Device not recognized. One of the usb devices attached to this computer has malfunctioned and windows does not recognize it".

Now when i purchased the laptop these ports working fine for about 3-4 months, but then started to have these issues. (i know im silly as could have had this fixed under the warranty - My bad!) Anyhoos. ive had this problem for over 3 years now and unable to connect any usb device.

Having tried unistalling the devices in device manager in an attempt for them to auto update, i still have the same issue. If its a hardware issue then im stuffed and will end up buying a new laptop instead of new motherboard.

Any help would be greatly appreciated.
Reply
#2
ok your not going to like me very much now.

that is a hardware problem in the usb connection pins in the ports themselfs
what tends to happen is when you push a usb plug in to the port it crosses over the connection wires and shorts out the port.
the bios then shut down that port to stop it from crashing the machine, problem is windows then see's the device but then finds no power
going to so does not recognize it.
this is becoming a common problem on some well used usb ports now days.

take the laptop over to a window, look inisde the usb port, you should just be able to see the connection pins.
if some are sitting higher then the others the port has worn
Reply
#3
Thanks for your help....What a bummer! (the problem that is, lol)

When i do connect lets say my ipod or mobile, windows shows as "Unkown Device" despite installing the relevent software for them. Although not connected, power definatley is going through as the items are being charged whilst connected.

Is it common for all the 4 ports to have the same issue?
Reply
#4
after seeing your reply i started reading more about this problem.
if your getting power out of the ports they should really be working, its only when they short out you get these sort of problems but then if you short a port thats it no power no nothing really.

from what i have been reading that laptop has VIA usb ports that are linked in to the main ATI chipset.
thats a right mix and match to start with.

i need to know something so i can check with via if any update drivers are about for vista.

go in to device manager, double click the usb hub,it will open a new box, click details tab or hardware tab,
i need to know the device id string of the main usb hub.

from what i have been reading at Fujitsu this is a very common problem with this laptop and your really not alone with the usb port problem.
http://forum.ts.fujitsu.com/forum/viewto...89&t=30298

one other thing i can think of to do and this might slow the usb port speed down but might get them to work.
go in to your bios, look over all the menus and sub menus for the usb ports
when you find it set them to usb legacy support enabled save and exit your bios.

that will set the ports to hot swapable but may downgrade them to usb 1.1 support only, but if it gets them sort of working its better then a kick in the nuts
Reply
#5
From your instructions heres the info you requested: In device manager when i click on usb hub it doesnt open new box but unhides the 3 controllers and 3 usb root hubs. doesnt give any options to click details or hardware tab other than scan for hardware changes or update drivers (which i have done and states my current version is upto date). heres the id for the controllers: first 2 named ATI/O Communications Processer USB 1.1 OHCI controller. The 3rd is ATI/O Communications Processor USB 2.0 EHCI controller.

Amongst my searches to find a resoloution to my problem i have come accross that fujitsu thread before, non of the recomendations worked for me.

I'll come back to you after i have tried to change the bios settings.
after check bois settings. usb legacy support was already enabled.
Reply
#6
i just started up in windows 7 just to make sure i was not going mad or told you how what to do wrong.

however it should be telling you the info i need.
i admit i hate vista i refuse to use vista iits a big no no in my book.
but windows 7 does work the same way as vista on alot of things inc device manager.

look in device manager and open the system usb controllers.
then double left click on one of the controllers and this should happen.
[Image: usb.jpg]

then click the details tab, then in the pull down box device id
if it still refuses to do it i would think there is a hardware problem in the controller and that means new motherboard.
or if that laptop has the pcmcia slot in it you can get pcmcia to usb cards, its not a great way of getting usb slots, however if the motherboard is up the creek its alot cheaper then repairing the laptop or replacing it.
i am suprised no one else on the net has not had this idea really but this is the sort of thing i was thinking about to get you out of trouble.
http://cgi.ebay.co.uk/Inside-hide-AKE-PC...2c588aa386
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Fujitech: USB Device Not Recognized CHESTER 1 3,711 07-07-2008, 01:17 PM
Last Post: davey6



Users browsing this thread: 1 Guest(s)