Copyright Daves Drivers 2007-2017

Facebook Share

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
SATA Drivers for XP Install on HP dv2550se
#41
you need the geforce 8M , thats a new geforce for laptops and the reason why its being a pain,
you can try and force the forceware driver from nvidia, it won't auto install as HP is not listed in its inf file it may allow you to force just the driver from device manager.
http://www.nvidia.com/object/winxp_175.19_whql.html

now as the laptop2go set was based on they above drivers with a mod to the INF files to allow them to install on any laptop they should have worked.

the way to force that is simple.
download what ever driver you want to try,
unpack the driver in to a folder on your desktop, in the case of the main forceware driver from nvidia that will mean trying to install it.
as the install starts you tell it to unpack its files in to a pre made folder or it will unpack in to c:nvidia 175_19
then use device manager , update driver option , search yourself and point it to the unpacked files.
now these are all brand new drivers they need the latest direct x or they won't install, make sure your direct x is fully up to date.
http://www.microsoft.com/downloads/detai...laylang=en
Reply
#42
(08-27-2007, 03:29 AM)EliCash Wrote: Thanks very much! I really appreciate your help! I had already done the same thing myself though. I made the floppy with the Intel tool and copied them back to the hard drive as I suggested above. I didn't know the tool actually contained the drivers initially - I thought it would ask me to point it at them and then create the floppy. It was easy to integrate the right driver (Intel 82801 HEM/HBM SATA AHCI Controller) on a custom install cd with nLite. XP installed with no problems using this cd. I used Vista Boot Pro to restore Vista's bootloader and add XP to the OS list. XP and Vista both boot now. I just have to find some other drivers for XP... the following are missing drivers according to XP's Device Manager. I've written what each is or what I think each is in brackets...

Audio Device on High Definition Audio Bus
(Conexant High Definition Audio)

Base System Device
Base System Device
Base System Device
(I don't know what these are)

Ethernet Controller
(Marvell Yukon 88E8039 PCI-E Fast Ethernet Controller or perhaps Intel PRO/Wireless 3945ABG Network Connection. Probably the Marvell?)

Modem Device on High Definition Audio Bus
(HDAUDIO Soft Data Fax Modem with SmartCP)

Network Controller
(Marvell Yukon 88E8039 PCI-E Fast Ethernet Controller or perhaps Intel PRO/Wireless 3945ABG Network Connection. Not sure about Ethernet/Network controller really. Maybe Ethernet is the Marvell and Network is the Intel?)

SM Bus Controller
(I don't know what this is)

Video Controller
Video Controller (VGA Compatible)
(Mobile Intel 965 Express Chipset Family)


I noticed this page on your forum... http://www.davesdrivers.com/forum/showth...hp?tid=322

Perhaps some of those drivers would be useful to me? If not, perhaps you could point me in the right direction? If I/we get everything working.. I'd be glad to post detailed instructions for others. Thanks again for all your help!!!

Hey EliCash you said that you got most of the drivers working except for some you posted, canyou tell me where did you get these:
Video Controller
Video Controller (VGA Compatible)
(Mobile Intel 965 Express Chipset Family)

Hey davey I try to run the installer and it tells me that my computer doesn't have any compatible hardware, even if I try to force it through the method you listed it still doesn't find them, thank you anyway
Reply
#43
have you loaded the main INF file from intel ?
that will clear the sm bus error.
http://downloadcenter.intel.com/Detail_D...l&lang=eng

base devices could be card reader or quick keys/hotkeys
download what hp do offer for this laptop under xp and install it.
http://h10025.www1.hp.com/ewfrf/wc/softw...53&lang=en

if you have a card reader this is the most common one.
http://h10025.www1.hp.com/ewfrf/wc/gener...R1002_UKEN

this driver will run the marvell lan http://www.marvell.com/drivers/driverDis...iverId=202

and this one the intel wifi
http://downloadcenter.intel.com/Detail_D...l&lang=eng

modem http://www.davesdrivers.com/drivers/hp%2...0modem.cab

conexant sound will need to be forced only after the UAA driver has been installed , download all i have here and try the install from device manager only.
http://www.davesdrivers.com/forum/showth...30#pid3530

after that lot is installed and the system is stable try forcing the nvidia drivers again, reason being with the main chipset driver missing xp may not be seeing the pci lane the chip is sitting on.

that lot should keep you busy for a while.
just make sure your running xp pro with service pack 2 do not use service pack 3 till the laptop is up running with all devices installed
Reply
#44
(08-25-2008, 06:41 PM)davey6 Wrote: have you loaded the main INF file from intel ?
that will clear the sm bus error.
http://downloadcenter.intel.com/Detail_D...l&lang=eng

base devices could be card reader or quick keys/hotkeys
download what hp do offer for this laptop under xp and install it.
http://h10025.www1.hp.com/ewfrf/wc/softw...53&lang=en

if you have a card reader this is the most common one.
http://h10025.www1.hp.com/ewfrf/wc/gener...R1002_UKEN

this driver will run the marvell lan http://www.marvell.com/drivers/driverDis...iverId=202

and this one the intel wifi
http://downloadcenter.intel.com/Detail_D...l&lang=eng

modem http://www.davesdrivers.com/drivers/hp%2...0modem.cab

conexant sound will need to be forced only after the UAA driver has been installed , download all i have here and try the install from device manager only.
http://www.davesdrivers.com/forum/showth...30#pid3530

after that lot is installed and the system is stable try forcing the nvidia drivers again, reason being with the main chipset driver missing xp may not be seeing the pci lane the chip is sitting on.

that lot should keep you busy for a while.
just make sure your running xp pro with service pack 2 do not use service pack 3 till the laptop is up running with all devices installed

Hey davey, I downloaded some files from the Intel site and everything is perfect now, thank you very much for your help.
Reply
#45
i have the same problem i have hp dv2601tu...i jst wanted to knw the drivers u have given for sata will it work for me also..
Reply
#46
the dv2601tu is still based on the Intel 965 chipset so the SATA drivers listed will work
Reply
#47
The hardest part for me was getting the SATA drivers to work when i slipstreamed my xp cd. But i got almost everything to work thanks to this wonderful guide!
only thing left ? in my device manager is a SM bus controller... what did i miss, i dont know what that is for.
-Thanks again!
Reply
#48
sm bus controller is part of teh main Intel chipset 965.
did you remember to load up the desktop verion of the INF file ?

if not please do so from here.
http://downloadcenter.intel.com/Detail_D...l&lang=eng
Reply
#49
(09-11-2008, 07:34 AM)davey6 Wrote: sm bus controller is part of teh main Intel chipset 965.
did you remember to load up the desktop verion of the INF file ?

if not please do so from here.
http://downloadcenter.intel.com/Detail_D...l&lang=eng


I downloaded the 965 chipset and installed them (exe). dont know why that didnt get taken care of. is there a way i could unpack the driver and update manually?
Reply
#50
that should have done it.
have a read of this and do what intel say it should then clear the fault for you.
http://www.intel.com/support/chipsets/sb/cs-013541.htm
Reply
#51
i would also have a read of this.
http://www.intel.com/support/chipsets/in...ts+infmain&

it should confirm if the INF file loaded or not.

little tip , shut down all firewall's , anti virus , anti spyware programs while you install the main chipset drivers.
that can block a install,
with the intel INF file it will over write its self without a problem so you can try and load it again if need be
Reply
#52
OK, that did the trick!

That was the last missing driver so now I have successfully rid of vista and now I just have xp on my dv2550se.

I would like to thank everyone in this thread for the help, especially davey6 for the quick responses.

The only issue I have is the video card. For some reason it shows two drivers in the Device Manager. EX:

-DISPLAY ADAPTERS:
--Mobile Intel® 965 Express Chipset Family
--Mobile Intel® 965 Express Chipset Family

Then the laptop "DINGS" continuously back and forth between the two.
So I disabled the 1st one and had to restart. I don't have the advanced video options anymore but I can max the res of the lcd out still. Most importantly no more "DINGING"

Anyone know why it installed two adapters? Or has anyone had that problem?

Thanks again guys!
Reply
#53
you could remove both by device manager then use, add remove programs and remove the display driver's
restart and load just one driver.
it should clear your last fault.
Reply
#54
Was looking at the specs on this HP dv2550se model, and noticed it has s-video and a monitor out, besides the lcd screen. Could be it set up the external video feeds as a separate driver set.
Reply
#55
(09-12-2008, 02:40 PM)pasound Wrote: Was looking at the specs on this HP dv2550se model, and noticed it has s-video and a monitor out, besides the lcd screen. Could be it set up the external video feeds as a separate driver set.

Do I use the Intel 965 Express driver for the video and the tv out driver? Because thats what happened when I installed the Intel 965 Express video driver.

Ive been getting random video card errors and then I have to reboot to fix it. What happened was all the color went low bit, and the resolution went down. :compu2:

EDIT:
Error: igxprd32 display driver has stopped working.

after restart i get the error..
C:\DOCUME~1\Nikki\LOCALS~1\Temp\WERae83.dir00\Mini091708-02.dmp
C:\DOCUME~1\Nikki\LOCALS~1\Temp\WERae83.dir00\sysdata.xml
Reply
#56
gooooooooooooooood
Reply
#57
(09-17-2008, 11:31 PM)hardwire Wrote:
(09-12-2008, 02:40 PM)pasound Wrote: Was looking at the specs on this HP dv2550se model, and noticed it has s-video and a monitor out, besides the lcd screen. Could be it set up the external video feeds as a separate driver set.

Do I use the Intel 965 Express driver for the video and the tv out driver? Because thats what happened when I installed the Intel 965 Express video driver.

Ive been getting random video card errors and then I have to reboot to fix it. What happened was all the color went low bit, and the resolution went down. :compu2:

EDIT:
Error: igxprd32 display driver has stopped working.

after restart i get the error..
C:\DOCUME~1\Nikki\LOCALS~1\Temp\WERae83.dir00\Mini091708-02.dmp
C:\DOCUME~1\Nikki\LOCALS~1\Temp\WERae83.dir00\sysdata.xml

I also get this error, is there any way to get rid of it? It happens so often that I've been thinking of upgrading to the Windows 7 RC just to get rid of it
Reply
#58
there is no way to rid yorself of that error under windows xp ( any version )
windows is reading the onboard gfx card as two cards one for the main lcd and one for the vga/svga out.

the only way you can stop this is to disbale the second intel 965 listed in device manager leaving just the main lcd one listed and enabled.

the newest set of drivers from intel can be found here.
http://downloadcenter.intel.com/Detail_D...me=Windows* XP Professional&lang=eng

the other thing that might be causing problems would be if you have a tv card installed in that laptop and windows has listed it as the intel which its not.
check your hardware spec as it came shipped and see if you have a tv card installed in that machine.
Reply
#59
Okay thanks, I'm gonna try to disable the second card to see if that works
Reply
#60
(08-26-2007, 09:34 PM)davey6 Wrote: I cheated for you Grin

I just made the floppy on my desktop, copied all files from that floppy and put them in to one folder and zipped it.

you will find it on the bottom of this post.

should be all you need to install xp.

now if you want to do a dual boot but keep vista please follow this guide which i have followed myself once and it does work ,
just don't rush it read and do at the same time if its possible, that way you can double check on what your doing.
http://www.syschat.com/dual-boot-vista-x...-1946.html

Dude, you have saved the day, I was having same problem with same drivers for a japanese panasonic laptop (CF-Y7), tried your zipped drivers and voila!! the xp installation finally detected my hd

Thanks!!!
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  [split] ULi Sata HD drivers Armani22 1 2,550 10-29-2013, 08:57 AM
Last Post: davey6
  ULi Sata HD drivers Jeff Mudway 3 4,444 05-25-2012, 01:33 PM
Last Post: davey6
  SATA drivers for m8120n HP media desktop parksdvd1979 2 6,601 01-17-2010, 06:00 PM
Last Post: davey6
  sata driver for xp install on HP dv9910us us-kiwi 1 7,442 08-27-2008, 07:26 AM
Last Post: davey6
  intel 82801 hem/hbm sata achi controller drivers Frank T 2 13,482 06-18-2008, 01:38 AM
Last Post: pasound



Users browsing this thread: 1 Guest(s)