Copyright Daves Drivers 2007-2017

Facebook Share

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
C-Media AC97 Audio Driver Version 5.12.1.51
#1
Slap
Hi this is my first post on this site, I'm hoping you can resolve this issue with my sound.
I have the dreaded ! next to the C-Media AC97 driver in device manager, I have tried to uninstall the driver then go through the re-install again, but it shows code 10 fault.
There is no speaker icon in the task bar and the volume symbol is 'greyed' out.
I have tried to install several drivers through C-Media ect, but still nothing but a blank!Nono
Any help would be most appreciated.
Thanks.
Reply
#2
Laptop? What's the make and model? Were you doing a downgrade to XP from Vista?

...sorry for the questions, but we need a little more info. thanks!
Reply
#3
C-media is common onboard sound and so is realtek but windows does class some realtek as c-media and adds to the confusion of people.
really need to know what this computer is or the make and model number of your motherboard to help you.

if your unsure look in the download section below / software / everest

download and install everst on your computer.

then remove all c-media drivers you have loaded to date, that will stop everest misreading.

now run everest.
in the left hand list click motherboard , then in the large box click motherboard again.
please post back with the report everest gives you and we can take a look and try and find you the correct sound card driver.
Reply
#4
Thinking
Thank you for your reply, I am just having a 'moment' trying to figure how to get to your everest link to download, please be patient, I am trying!!
I have had a look around the site but not been able to locate it, sorry!!
Thanks again.
Reply
#5
its right here.
http://www.davesdrivers.com/forum/showth...hp?tid=656
Reply
#6
Hi Davey6 hope the info below is what you are looking for, thanks for the link!
--------[ EVEREST Home Edition © 2003-2005 Lavalys, Inc. ]------------------------------------------------------------

Version EVEREST v2.20.405
Homepage http://www.lavalys.com/
Report Type Report Wizard
Computer USER-6AP4TNUX6B
Generator Owner
Operating System Microsoft Windows XP Professional 5.1.2600 (WinXP Retail)
Date 2008-04-24
Time 22:17


--------[ Summary ]-----------------------------------------------------------------------------------------------------

Computer:
Operating System Microsoft Windows XP Professional
OS Service Pack Service Pack 2
DirectX 4.09.00.0904 (DirectX 9.0c)
Computer Name USER-6AP4TNUX6B
User Name Owner

Motherboard:
CPU Type AMD Sempron, 1600 MHz (8 x 200) 2600+
Motherboard Name ECS 760GX-M (3 PCI, 1 AGP, 2 DDR DIMM, Audio, Video, LAN)
Motherboard Chipset SiS 760GX, AMD Hammer
System Memory 224 MB (PC2700 DDR SDRAM)
BIOS Type Award (08/26/05)
Communication Port Communications Port (COM1)
Communication Port ECP Printer Port (LPT1)

Display:
Video Adapter SiS 650/651/740/661FX/741/760 series (32 MB)
3D Accelerator SiS 330 Mirage Integrated
Monitor Plug and Play Monitor [NoDB] (13011)

Multimedia:
Audio Adapter SiS 7012 Audio Device

Storage:
IDE Controller SiS 5513 IDE UDMA Controller
SCSI/RAID Controller SiS 180 RAID Controller
Floppy Drive Floppy disk drive
Disk Drive Maxtor 6Y080L0 (80 GB, 7200 RPM, Ultra-ATA/133)
Optical Drive LITE-ON LTR-48125S (48x/12x/48x CD-RW)
Optical Drive PIONEER DVD-ROM DVD-115 (16x/40x DVD-ROM)
SMART Hard Disks Status OK

Partitions:
C: (NTFS) 78152 MB (60679 MB free)

Input:
Keyboard HID Keyboard Device
Mouse HID-compliant mouse

Network:
Network Adapter Realtek RTL8139/810x Family Fast Ethernet NIC (192.168.1.65)
Modem Lucent Win Modem
Reply
#7
thats strange but i will try this first. if it don't work i will try another way.
everest list your motherboard as the ECS 760GX-M

ecs list your sound as realtek.

please click this link and scroll down to RealTek Codec Sound on board driver
http://www.ecs.com.tw/ECSWebSite/Product...=1&LanID=0

download and install that driver, if ecs is correct your sound will work after you restart the computer
Reply
#8
Grin
Good news! The driver has downloaded and when I try the speakers through the speaker test of audio sound manager, I get sound!!
Unfortunately I am not getting any sounds through the normal operation of the PC, and when I start up I get an error message 'RUNDLL Error loading cmicnfg.cpl The specified module could not be found' , any ideas?
Reply
#9
ok you need to do a little work.

the error cmicnfg.cpl is down to the c-media drivers you have loaded in the past and you have a reg key still in place so windows is trying to load up a c-media driver every single time you start the computer and its messing up the realtek driver which is the one you need.

now you need to go in to add rmove programs and remove all the c-media and realtek sound card drivers ,
restart the pc.
then take a read of this is will explan how to get rid of the last few c-media files.
http://www.daniweb.com/forums/thread25517.html

once you have a clean system go back to ecs and install the sound card driver once more and you should have your sound back to normal.

now if that is all too much for you and you don't really like editing the reg you can try this.
click start , control panel , sounds and audio devices.
click the sounds tab, if possible select a windows scheme default is best.
click apply , ok and restart the computer.
now you may well have your sounds back but you will have to live with the cmicnfg.cpl popping up each time you start the computer.
Reply
#10
Hi Davey6. Thanks for your patience, I have tried all you suggested and although I have realtrak sound installed with the icon in the tool bar, I have tried to do exactly as you suggested about just getting sound with the RUNDLL message coming up, I guess I can live with that.
Unfortunately I still have no sound, when I go into Sounds and Audio devices, then go to sounds, I have 'Windows Default' showing, when I get it to highlight, then press apply, then OK, then restart, I still have no luck!
I have had ago at the other site you mentioned and not been able to totally clear everything with that either, I reckon I must be doing something wrong?!
Comp1
Reply
#11
*** edited by davey6 ***

no freebe ads.
i catch you again and i will ban you from this site.
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  ac97 driver help no sound pintygirl 12 6,293 06-20-2008, 02:37 PM
Last Post: pintygirl
  [split] C-Media AC97 Audio Driver Version 5.12.1.51 cherop 2 5,043 04-26-2008, 02:05 PM
Last Post: davey6
  Cmedia AC97? bq3066 1 2,140 10-08-2007, 07:57 AM
Last Post: davey6
  C-MEDIA AC97 AUDIO DEVICE #2 no sound help im stupid BillyBong 3 4,387 05-11-2007, 07:42 AM
Last Post: BillyBong
  Post: #1c-media AC97 audio device driver HELP ME!!!! 28daniel28 51 31,308 05-01-2007, 07:35 AM
Last Post: davey6



Users browsing this thread: 1 Guest(s)